Results 1 to 10 of 10

Thread: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

  1. #1
    Join Date
    Oct 2011
    Posts
    67

    Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    I tried to connect my laptop to my TV, which works to the display of my desktop on my TV, so far so good. Nevertheless I tried to play several sound, nevertheless I cannot hear anything. In all other positions in the play-l HDMI display device, not in my case. I installed the most recent nvidia driver from nvidia site. Have someone an thought why I cannot observe the HDMI?

  2. #2
    Join Date
    Oct 2011
    Posts
    75

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Can you twist HDMI audio somewhere on the NVidia X Server Settings program?

    Code:
    inxi ĖGx

  3. #3
    Join Date
    Nov 2010
    Posts
    368

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    I searched but I cannot discover an environment.
    Code:
    sa@sa-X71SL ~ $ inxi -Gx
    Graphics:  Card nVidia G98 [GeForce 9300M GS] X.Org 1.9.0 Res: 1440x900@50.0hz 
    GLX Renderer GeForce 9300M GS/PCI/SSE2 GLX Version 3.3.0 NVIDIA 280.13 Direct Rendering Yes

  4. #4
    Join Date
    Dec 2010
    Posts
    409

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    This PPA is stable source code versions of the components of X.org. If you are looking for something more bleeding-edge, please see the xorg-edgers PPA. Or, if you really want to stack X backports current stable release of Ubuntu more, observe x-backports PPA.

    While Ubuntu-X is not officially supported by these packages, if you find troubles when installing these debs do not hesitate to report bugs to Launchpad. However, be sure to make clear that you are running the packages from this PPA for all we know of the corrections to come here.

    If you are upgrading from one version to another with PPA is enabled, please, install the ppa-purge and use it to cut everything in advance here. ppa ppa-purge sudo: Ubuntu-x-swat/x-updates will.

  5. #5
    Join Date
    Oct 2011
    Posts
    64

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Now I have update kernel 2.6.38-10-generic-pae.But there is still no HDMI card. Driver or someone has this card working?

  6. #6
    Join Date
    Mar 2011
    Posts
    359

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Quote Originally Posted by !Shea! View Post
    Now I have update kernel 2.6.38-10-generic-pae.But there is still no HDMI card. Driver or someone has this card working?
    The driver is not open source; the Mint people cannot modify whatever thing inside. The open source driver will not hold up HDMI audio before kernel 3.2 or 3.3.

  7. #7
    Join Date
    May 2011
    Posts
    416

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Code:
    ma@molinux ~ $ aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    front:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        Front speakers
    surround40:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    hdmi:CARD=SIS966,DEV=0
        HDA SIS966, ALC663 Digital
        HDMI Audio Output
    Nevertheless i canít acquire 5.1 on this device hdmi: CARD=SIS966, DEV=0 someone any thoughts

  8. #8
    Join Date
    Oct 2011
    Posts
    51

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Have you checked the BIOS settings to make sure onboard audio is set to auto? I imagine if you set to Enabled, the onboard audio only detected / activated. And while you're there, give pleasure to verify the HDMI settings.

    Attempt restarting with S / PDIF mode off. Television, video capabilities and audio are perceive at boot time. Have you attempt booting the laptop with the HDMI connection, the TV on and the TV volume is not hushed? TVís HDMI and audio input settings?

  9. #9
    Join Date
    May 2011
    Posts
    344

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Quote Originally Posted by DIMINUTIVE! View Post
    Have you checked the BIOS settings to make sure onboard audio is set to auto? I imagine if you set to Enabled, the onboard audio only detected / activated. And while you're there, give pleasure to verify the HDMI settings.

    Attempt restarting with S / PDIF mode off. Television, video capabilities and audio are perceive at boot time. Have you attempt booting the laptop with the HDMI connection, the TV on and the TV volume is not hushed? TVís HDMI and audio input settings?
    Running on the HDMI, I also attempt this

    Code:
    /etc/pulse/daemon.conf 
    
    ; default-sample-channels = 6
    ; default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

  10. #10
    Join Date
    Jul 2011
    Posts
    291

    Re: Unable to get sound using Nvidia 9300m GS via HDMI in Linux mint

    Some older audio receivers may require firmware update to recover compatibility HDMI. If you are using a HDMI switch, it is probable that the PC is not negotiating an appropriate handshake with the display device. Please join your PC straight to your display device if possible. If your display has multiple audio inputs HDMI source, it is probable that the strength of digital audio on the display to permit the PC to appropriately become aware of the audio capabilities of the display.

Similar Threads

  1. HDMI not working for Audio on Linux Mint
    By Roakman in forum Operating Systems
    Replies: 5
    Last Post: 15-01-2011, 07:42 AM
  2. Linux Mint: NVIDIA GTX 460 HDMI audio not working
    By Mustafa k in forum Monitor & Video Cards
    Replies: 5
    Last Post: 13-01-2011, 06:34 AM
  3. Unable to get hdmi sound from my laptop over Nvidia
    By PsychoVillan in forum Monitor & Video Cards
    Replies: 3
    Last Post: 11-01-2011, 05:54 PM
  4. How to overclock Nvidia 9300m gs
    By Maranello in forum Monitor & Video Cards
    Replies: 3
    Last Post: 07-07-2009, 04:48 PM
  5. NVIDIA GeForce 9300M GS
    By Flaco in forum Monitor & Video Cards
    Replies: 3
    Last Post: 16-02-2009, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •