Go Back   TechArena Community > Hardware > Monitor & Video Cards
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 22-01-2011
Member
 
Join Date: Jan 2011
Posts: 27
ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

I selected an ATI 5670 yesterday for installing on my older Athlon 64 X2 system running the Gigabyte GA-K8N-SLI nforce motherboard. I inserted the memory card and I observe no picture on the display screen of the monitor. The system would boot up so I knew the card had to be working somehow, but I got no picture from the DVI or HDMI. Then I choose to verify the BIOS updates for that motherboard. Turns out Gigabyte have beta bios they launched for the motherboard in 09 that addressed problem using newer PCI-Express 2.0 as well as 2.1 graphic cards. So what should I do order to get my problem solve.
Reply With Quote
  #2  
Old 22-01-2011
Member
 
Join Date: Aug 2009
Posts: 772
Re: ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

I think that you must update the new BIOS setting which will be necessary. The attributes effecting HDMI/DVI require to be set properly in the BIOS as well as the new BIOS might have enabled while before it was not. Further, characteristically you cannot have concurrent HDMI + DVI connections in you one system. Perhaps too the newer BIOS consent to for concurrent output. This can also affect proper sound output. (E.g. computer connected to HDMI TV as well as DVI Monitor).
Reply With Quote
  #3  
Old 22-01-2011
Member
 
Join Date: May 2009
Posts: 759
Re: ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

The beta F10E undoubtedly offers not mentioned to get better VGA card compatibility with this video card inside this motherboard which positively could be 100% of the reason for achievement particularly on a 4 year old Motherboard with a much newer GPU. Obviously OLD + NEW frequently is certainly the difficulty {compatiblec} can be solve by new Bios setup. I did briefly look at your manual and noticed very sparse configurations. However, I did see Q-Flash which is the preferred as well as suggest BIOS flash method. I have the similar reason of yours which is to inform, and in most instances as a comparable problems {lately solved} as you've explain, for the mainly part have been credited in BIOS settings and/or in the GPU control panel and/or several connections {as well as unplug/plug - initialization}.
Reply With Quote
  #4  
Old 22-01-2011
Member
 
Join Date: May 2008
Posts: 871
Re: ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

I think that you must use the ATI 5770 graphic card which is a 2.1 graphic card and work properly with your motherboard. You will require using their utility option, the bios windows updater, as well as I had installed the new bios setting. Figured since I didn't make out on this relating to this precise board that seemed to be a pretty popular choice in the socket 939 era, it would be nice to have a topic somewhere to address those who want to upgrade their video cards to have one which windows 7 supports, as it didn't like my radeon x1900XT and considered it a "legacy" card.
Reply With Quote
  #5  
Old 05-10-2011
Member
 
Join Date: Oct 2011
Posts: 1
Re: ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

Old thread, well, aware, I'm always tardy to the party.
Put the card in the second PCIe slot, watch what happens.
Reply With Quote
  #6  
Old 10-04-2014
Member
 
Join Date: Apr 2014
Posts: 1
question Re: ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI

To Dredge: "What does happen when you put it in the second slot?"
Reply With Quote
Reply

  TechArena Community > Hardware > Monitor & Video Cards
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "ATI 5670 graphic card is not working in Gigabyte GA-K8N-SLI"
Thread Thread Starter Forum Replies Last Post
which graphic card for my board gigabyte g31m-es2l noob1016 Motherboard Processor & RAM 11 16-07-2012 11:18 AM
Does 1 PCI slot in Gigabyte GA-H55M-USB3 Motherboard is only for graphic card? Raju Shrivastav Motherboard Processor & RAM 6 21-12-2011 07:46 PM
Should I upgrade graphic card to Gigabyte ATI HD 5770 or Gigabyte GTX550Ti Ketaki Monitor & Video Cards 6 16-07-2011 10:32 PM
Gigabyte 6870 graphic card won't work Dabir Hardware Peripherals 4 22-03-2011 07:00 AM


All times are GMT +5.5. The time now is 07:16 AM.