Results 1 to 15 of 15

Thread: STDOLE2.TLB error message when opening Project

  1. #1
    Join Date
    Nov 2004
    Posts
    36

    STDOLE2.TLB error message when opening Project

    I am getting error when I am trying to open Microsoft Project 2003. It was installed recently and was working fine. Then I got a notification to update SP1 that I ignored. But when I try to open the same I was getting a error saying STDOLE2.TLB. This error I had faced long time ago on Office. I do not remember what I did to fix that. I am annoyed with the same. The error keeps on appearing and cannot goes away. I tried to run Windows Update and other stuff but still it does not worked. Should I re-install the same.

  2. #2
    Join Date
    Sep 2004
    Posts
    110

    Re: STDOLE2.TLB error message when opening Project

    I think your setup is corrupted due to which you are getting the problem. It is better if you can simply re-install the stuff from scratch and then check back. I am using the same version on Windows XP SP2. You can start with setup and then check back the same. If still you are getting then you will need to replace the setup media and check again. It can be due to some internal system file failure.

  3. #3
    Join Date
    May 2007
    Posts
    3
    In registry Give set value permissions to HKCR\TypeLib\{00020430-0000-0000-C000-000000000046}\2.0\0\win32 key

  4. #4
    Join Date
    Jun 2007
    Location
    Solomon Islands
    Posts
    4

    MS Project error

    hi, i've got the same problem with my MS project on Vista, please give me some more info on how to solve.
    Thanks
    matrix

  5. #5
    Join Date
    May 2007
    Posts
    3
    Matrix

    Are you familiar with the registry? We had the problem on Windows XP where the std build is locked down for users. It turned out to be registry permissions on the key mentioned above. If you need to know how to correct, just relpy, and I will put the steps on.


    Quote Originally Posted by matrix View Post
    hi, i've got the same problem with my MS project on Vista, please give me some more info on how to solve.
    Thanks
    matrix

  6. #6
    Join Date
    Jun 2007
    Location
    Solomon Islands
    Posts
    4

    Re:ms Project

    Yes i am familiar with registry, but can you just point me to the right path,
    thanks mate
    matrix

  7. #7
    Join Date
    May 2007
    Posts
    3
    Open reg and expand HKEY_CLASSES_ROOT then browse to TypeLib\{00020430-0000-0000-C000-000000000046}\2.0\0\win32 - then right click on that Key and choose permissions, give users groups FULL control. If that doesn't sort then make sure they can brosw to the path in the default value such ie...C:\WINDOWS\system32\stdole2.tlb , could also try copying the file from a working pc to see if that sorts.

    If you can't see HKEY_CLASSES_ROOT, it can also be found under HKEY_LOCAL_MACHINE > Software > Classes. Classes is the same as HKEY_CLASSES_ROOT

    Cheers

  8. #8
    Join Date
    Jun 2007
    Location
    Solomon Islands
    Posts
    4

    Re:ms Project

    Thanks alot guys,let you guys know on my progress
    cheers
    matrix

  9. #9
    Join Date
    Jun 2007
    Location
    Solomon Islands
    Posts
    4

    Successfull MS Project

    Thanks alot sted,
    the registry actually worked..no more messages popping up..
    thanks
    matrix

  10. #10
    Join Date
    Oct 2007
    Posts
    1
    I've tried both solutions and both seem to be locked out because of permissions.

    1) tried renaming stdole.tlb to stdole.old
    file secured and only have READ access;
    even though I am the administrator.

    2) tried registry edit and the following msg appeard:
    "Unable to change permission changes on win32.
    Access is denied."

    I do have this file from previous desktop that is working fine.

    Any additionalsuggestions?

  11. #11
    Mike Glen Guest

    Re: STDOLE2.TLB error message when opening Project

    What version of Project are you using? Where did you get guidance on the 2
    solutions? Have you tried re-installing Project?

    FAQs, companion products and other useful Project information can be seen at
    this web address: http://project.mvps.org/faqs.htm

    Hope this helps - please let us know how you get on :)

  12. #12
    Schlidm1 Guest

    Re: STDOLE2.TLB error message when opening Project

    I am receiving the same error message as in the original Post. The error is
    diplayed upon first opening of the Project 2003 app. The error is "The file
    "STDOLE2.TLB" cannot be found or contains a Visual Basic for Applications
    library that is not valid. Verify that the file name is correct, and then
    try again. If the Visual Basic for Applications library is invalid,
    reinstall Project."

    The version of Project 2003 has been installed, followed by the installation
    of SP2 for Project 2003. I have not moved to SP3 yet since our environment
    has not been approved to use it. The machine is just built and has not been
    previously used, so the error was shown on the first run of the app.

    Trying the 2 previous posts that deal with permissions on the registry keys
    do not solve the problem. Users have full control both in the registry and
    of the actual .tlb file. But the error persists. Despite users that are
    admins or not.

    Any assistance is appreciated. Thanks in advance.

  13. #13
    Mike Glen Guest

    Re: STDOLE2.TLB error message when opening Project

    (I've been away) The problem is that your original post is blank! Still,
    reading between the lines, you have this error message when opening this
    project. Which procedure did you follow? Does it load any of your project
    or is this the first thing you see? Do you get a similar message with other
    projects? Does the project have customized macros, as this file seems to be
    vba specific? You could try the suggestions in FAQ Item: 43. Handling
    project file corruption and/or bloat.

    FAQs, companion products and other useful Project information can be seen at
    this web address:http://project.mvps.org/faqs.htm

    Hope this helps - please let us know how you get on :-)

  14. #14
    Join Date
    Dec 2013
    Posts
    1

    Re: STDOLE2.TLB error message when opening Project

    Hi Mike,

    I too get the same error when opening Project 2003 and not opening any .mpp file

    The file "STDOLE2.TLB" cannot be found or contains a Visual Basic for Applications library that is not valid. Verify that the file name is correct, and then try again. If the Visual Basic for Applications library is invalid, reinstall Project.

    I first started getting the error after downgrading to Project 2007 from Project 2010. This error continued after downgrading further to Project 2003.

    I have already tried the solutions suggested and still get the error.

    Any other suggestions are welcome

    Kind regards
    Pradeep

  15. #15
    Join Date
    Dec 2007
    Posts
    2,297

    Re: STDOLE2.TLB error message when opening Project

    Quote Originally Posted by Pradeep A P View Post
    Hi Mike,

    I too get the same error when opening Project 2003 and not opening any .mpp file

    The file "STDOLE2.TLB" cannot be found or contains a Visual Basic for Applications library that is not valid. Verify that the file name is correct, and then try again. If the Visual Basic for Applications library is invalid, reinstall Project.

    I first started getting the error after downgrading to Project 2007 from Project 2010. This error continued after downgrading further to Project 2003.

    I have already tried the solutions suggested and still get the error.

    Any other suggestions are welcome

    Kind regards
    Pradeep
    Try to run the Project 2007 in Compatability mode of Windows XP SP3 and see that whether the error goes away or not.

Similar Threads

  1. Replies: 5
    Last Post: 13-01-2012, 04:20 PM
  2. Replies: 3
    Last Post: 10-11-2010, 06:27 PM
  3. Error message when compiling SQL and C# project
    By Duck in forum Software Development
    Replies: 3
    Last Post: 01-12-2008, 01:13 PM
  4. Error message when opening Internet options on IE7
    By Renderman21 in forum Operating Systems
    Replies: 4
    Last Post: 20-09-2008, 06:23 PM
  5. Error message while opening up SKU111.CAB file
    By CostasD in forum MS Office Support
    Replies: 1
    Last Post: 14-03-2008, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •