Results 1 to 5 of 5

Thread: Unable to mount WD My Passport hard drive with Ubuntu

  1. #1
    Join Date
    Jan 2012
    Posts
    56

    Unable to mount WD My Passport hard drive with Ubuntu

    Well right now I am having WD My Passport. I am looking to mount my external hard drive by using ubuntu 10.04. but I am not able to do the same even while doing the same it is prompting with an error message. Any suggestions to overcome this particular problem will be highly appreciated. Thanks a lot in advance.

  2. #2
    Join Date
    Dec 2010
    Posts
    453

    Re: Unable to mount WD My Passport hard drive with Ubuntu

    My system is also powered by ubuntu 10.04. I backed up my external hard drive by simply using nfs4 and grsync. I used following command at the end of fstab.
    Code:
    /media/mybook/laptop_backup /export/laptop_backup none bind 0 0
    /media/mybook/laptop_D610 /export/laptop_D610 none bind 0 0
    /media/mybook/laptop_www /export/laptop_www none bind 0 0
    Above mentioned directories can be mounted as well as accessed via network connection. When I boot my computer it was prompted with an error message. Hence I executed below mentioned command to mount directories.

    Code:
    sudo mount –a
    you should know that there is no mount command in /etc/fstab. So simply add the following.
    Code:
    /dev/sdd1 /media/mybook type ext3
    However it failed at time of mounting directories. By after adding nobootwait option fixed the situation. It seems that nobootwait halts the booting until and unless mounting process get completed. Following are the command for /etc/fstab
    Code:
    /dev/sdd1 /media/mybook ext3 nobootwait 
    /media/mybook/laptop_backup /export/laptop_backup none bind 0 0 
    /media/mybook/laptop_D610 /export/laptop_D610 none bind 0 0 
    /media/mybook/laptop_www /export/laptop_www none bind 0 0 –

  3. #3
    Join Date
    May 2011
    Posts
    418

    Re: Unable to mount WD My Passport hard drive with Ubuntu

    In this particular situation you should look for program which is known as mountmanager into repositories. Even you can do the same by running below mentioned command.
    Code:
    sudo apt-get update
    sudo apt-get install mountmanager
    after successful installation of above mentioned command do the following steps.


    Simply go tot System, click Administration. Now click on Mount Manager. It would launch the MountManger program on your computer. Simply click on the drive that you wanted to automount available into the list provided. Now you should select the area for mount point. I was looking to mount my drive to be pointed to the /media/drive/ directory. Hence I have created the same and set mount point as well. After doing that same I clicked on Partition and clicked on Apply button. It simply modified fstab file. Once completed with all the above mentioned thing I simply restarted ny system.

    If above mentioned thing wont work for you than simply install ntfs-config and click on auto configure button when launch it first time on the computer. So try both the solutions and let me know whether it worked for you.

  4. #4
    Join Date
    May 2011
    Posts
    503

    Re: Unable to mount WD My Passport hard drive with Ubuntu

    The best solution that I can tell you is to edit fstab. You need to run following command on the terminal.
    Code:
    cp /etc/fstab /etc/fstab.orig
    You should have live CD/USB disk if any issue occurs.

  5. #5
    Join Date
    Jun 2011
    Posts
    871

    Re: Unable to mount WD My Passport hard drive with Ubuntu

    There could be several reason why it does not work for you. Could be issue cause by enhanced security by means of Apparmor or there could be something wrong happened with kernel as well. Also check out which file system do using on device. in case you are using FAT32 or NTFS the mount of device can be done easily. you might deal with permissions if drive has been formatted using Linux. Well in my situation below mentioned solution worked for me without creating much trouble so try the same and let me know if worked for you.
    Code:
    /apps/nautilus/preferences/
        media_automount = true
        media_automount_open = true
    once completed with execution of above mentioned command I installed usbmount by running following command.
    Code:
    sudo apt-get install usbmount

Similar Threads

  1. My Passport hard drive cannot be repaired in MAC OS X
    By Cham-D! in forum Hardware Peripherals
    Replies: 5
    Last Post: 22-05-2012, 03:43 PM
  2. WD Passport hard drive ejecting itself automatically
    By Scottish in forum Hardware Peripherals
    Replies: 2
    Last Post: 18-05-2012, 10:54 PM
  3. Western Digital passport hard disk doesn’t mount
    By Rashid in forum Hardware Peripherals
    Replies: 5
    Last Post: 23-03-2012, 11:28 AM
  4. Mount internal hard drive in ubuntu
    By LinuxeD in forum Operating Systems
    Replies: 3
    Last Post: 21-08-2009, 12:13 AM
  5. Ubuntu cannot mount CD/DVD drive
    By Saaz in forum Operating Systems
    Replies: 3
    Last Post: 31-07-2009, 12:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •