Go Back   TechArena Community > Hardware > Hardware Peripherals
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



WD Elements 2TB External hard drive not detected, although getting blinking light

Hardware Peripherals


Reply
 
Thread Tools Search this Thread
  #1  
Old 19-05-2012
Member
 
Join Date: Feb 2012
Posts: 38
WD Elements 2TB External hard drive not detected, although getting blinking light
  

I am having the WD Elements 2TB External hard drive which was working good for a few days but from last three days, I am facing some problem with that. Actually when I connect that with my computer then I can see that there is blinking light on WD hard drive but that is not getting detected by the system. I have tried by connecting that on different usb ports but with all the ports it is having the same problem. This is a brand new hard drive. I canít guess that what is the problem with that. Is there someone who has faced the same problem or have some suggestion useful in this case then please post that over here. I am having a lot of data on this and donít want to lose that. Please help.

Reply With Quote
  #2  
Old 19-05-2012
Member
 
Join Date: May 2011
Posts: 1,927
Re: WD Elements 2TB External hard drive not detected, although getting blinking light

What is the operating system that you are using in your computer? I am asking this because there are some of the Windows vista users who are facing this problem. Have you updated the widows vista of SP1? This problem happens while updating the Windows Vista PC to Windows Vista because the device driver gets reinstalled at that time. One of the simple ways to get this problem resolved is simply uninstalling and reinstalling the driver.

These drivers worked on Windows Vista RTM and on Windows Vista SP1. So, try by reinstalling the driver and if that does not help then reply back and so that we can provide you some alternate solution for this problem.
Reply With Quote
  #3  
Old 19-05-2012
Member
 
Join Date: Jun 2011
Posts: 1,999
Re: WD Elements 2TB External hard drive not detected, although getting blinking light

There is one possibility that you can try in your case. It is regarding the assignment of the drive letter. Here is the steps to get this resolved:
  1. Just right click on my computer and then select Manage
  2. Select option for Disk Management
  3. You must see the hard drive there but most probably it will not have any letter assigned to that drive.
  4. Right click on that drive and select Change drive letter.
  5. Now click on ďAddĒ and then assign some drive letter to that.
Reply With Quote
  #4  
Old 19-05-2012
Member
 
Join Date: Jul 2011
Posts: 2,010
Re: WD Elements 2TB External hard drive not detected, although getting blinking light

I think that you will have to format your drive in order to use that. But with this process, you will lose all your data from the drive. If you donít want to lose data from your drive then there is one trick for that. You will just have start your computer in with the Ubuntu live CD and then connect your drive. Take the backup for your data and after that disconnect drive from it, start your computer in windows mode. Now you can proceed with the below mentioned process.

This is for the users who are running Windows XP on their computer. First of all, right click on my computer and from there select the manage option. When you do that then it will open the Computer Management window. Now, you will have to go to the Storage category and from there choose Disk Management. Now, you will have to right click on the new drive and select "initialize". This new hard drive is normally listed as the Hard Disk 1. Here you will be given two options, one as partition and other as format. You will have to select NTFS- Quick Format from there and confirm you selection. It will take some time for completing the process. This time differ according to total data on your drive. Now you will be able to use your drive without any problem.
Reply With Quote
Reply

  TechArena Community > Hardware > Hardware Peripherals
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "WD Elements 2TB External hard drive not detected, although getting blinking light"
Thread Thread Starter Forum Replies Last Post
unable to access western digital elements 1023 External Hard Drive Sereno Hardware Peripherals 8 22-03-2012 11:32 PM
Seagate External Hard drive not detected Samarth Hardware Peripherals 20 25-11-2011 12:56 AM
External Hard Drive Not Detected The$Achilles Operating Systems 7 10-09-2010 01:09 AM
External USB 2.0 hard drive is not detected Viensterrr Hardware Peripherals 3 16-02-2009 05:23 PM
USB External Hard Drive Not Detected akbar Vista Hardware Devices 1 11-10-2008 03:57 AM


All times are GMT +5.5. The time now is 09:19 PM.