Go Back   TechArena Community > Hardware > Hardware Peripherals
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 01-03-2012
Member
 
Join Date: Nov 2011
Posts: 47
Help with Megatech Maxima500 UPS

Alright, so i have a Megatech Maxima500 UPS. it has software monitoring through com port which isnt functional atm since it doesnt hav windows 7 drivers & my present board isnt having a com port either. It shows 500va 300W behind.
previously used it on a pc with VIP 400W smps, amd athlonXP 2400+, asus a7n8xvm400, 2X 512MB ddr, 80gb ide hdd, lg dvd writer, nvidia fx5500 & a couple of 80mm cabin fans. gave me 20-30mins backup without the monitor hooked to it. the backup time would keep reducing as the battery got older & by a year it used to give just about 5mins by when i would change to new battery.
but off late after changing to new battery it kills the battery somehow before the warranty expires. when i wasnt sure it was problematic i have got 2-3 batteries replaced on warranty. the batteries usually leaked, bloated & few looked fine. at first i thought it was the cheap battery that were faulty. used some cheap readily available brands as exide was tough to find. addo, amco were some.
The battery guys said my ups was overcharging & that was killing the battery.
So before i changed to another battery i took the UPS to a technician who said he fixed some resistance etc.. & he put a new battery. dont feel its fixed yet or wat, but the battery is dead again.
is it because of my new system config is too much for it to handle? my new system config is amd phenomII x4 955be, ga-880gm-usb3, corsair 4gb ddr3 1600, wd green 1tb sata hdd, lg dvd writer, 3X 80mm cabin fans. changed to seasonic x-850W this week, before that i used vip 600W smps. am also planning to add a gpu to this config. 32" sony bravia used as monitor, but its not on backup.
shud i change to a higher capacity ups? is my new config too much for the 500W ups as i feel or is the ups simply bust?
if i need a ups change, then wat are my options?
(dont need to have display on backup. simply want to safely shutdown pressing the power button if electricity isnt back in a couple of mins)
Reply With Quote
  #2  
Old 02-03-2012
Member
 
Join Date: Apr 2008
Posts: 586
Re: Help with Megatech Maxima500 UPS

Why do you want to use a UPS when the psu alone can handle the electric flow pretty much, if there isnt any problem related to power cuts every now and then. Well, if you know how to check, then check the circuit breaker on the back is pushed in or not. Replacement batteries are far more expensive than buying a new UPS itself.
Reply With Quote
  #3  
Old 02-03-2012
Member
 
Join Date: Nov 2011
Posts: 47
Re: Help with Megatech Maxima500 UPS

Quote:
Originally Posted by spearMan View Post
Why do you want to use a UPS when the psu alone can handle the electric flow pretty much, if there isnt any problem related to power cuts every now and then. Well, if you know how to check, then check the circuit breaker on the back is pushed in or not. Replacement batteries are far more expensive than buying a new UPS itself.
there are frequent power cuts here, or else i wouldnt be looking to buy another ups. i am also aware that replacement batteries are also far more expensive than buying a new ups.
btw ive realised that the seasonic x-850 power supply that i own has active pfc, so i should be looking to buy a ups which has a pure sine wave output.

guys plz suggest some brands/models u might know of as good. should i be looking at utl, mikrotek, sukam, powersafe?
Reply With Quote
  #4  
Old 02-03-2012
Member
 
Join Date: Nov 2011
Posts: 47
Re: Help with Megatech Maxima500 UPS

enquired about iball, apc, utl, sukam, numeric.
iball seller didnt hav in stock.
utl guy quoted 16k for 800va ups with pure sine wave output with 150ah bosch battery & 29k for 1250va ups also with pure sine wave output with 2x 150am batteries.
sukam guy quoted 19.8k for 1.4kv ups with pur sine wave output with 2x 100ah batteries & 13k for 1kv ups also with pure sine wave output with 100ah battery
numeric seller wanted to sell me some 500 or 600va ups :p
apc guy suggested back-ups es 650, 700, back-ups rs 800, 1000, back-ups 1000 or 1500. asked him if the 650 model could handle the load. presently hav a 650 on my always on download rig, so he asked me to chek my newer rig on it. checked 650 on newer rig & tried switching on/off multiple times. all seemed fine, no buzz/humm either. so i went back & picked up the 1100va model without usb software monitoring just to be on the safe side after i put a gpu on rig. opted out of the monitoring software since this pc isnt left on unattended.
so anywayz i picked up the 1100 model for rs.5460/- including 5% vat.
anywayz after i got home i connected the ups to power socket for 12hours charging, but no lites showed up. so i thought it was since the battery didnt hold any charge, so i waited for about & hour & tried hitting the power button again, but still nothing. so i called up the apc helpline & told wat transpired. he took some details like my model no, serial no, name, address, contacts etc then told me to open the cover underneath the ups which held batteries & see if wire wasnt connected :p & guess wat, it wasnt
Reply With Quote
Reply

  TechArena Community > Hardware > Hardware Peripherals
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT +5.5. The time now is 09:03 AM.