Results 1 to 5 of 5

Thread: Speakers switching position on X-FI Elite Pro

  1. #1
    Join Date
    Dec 2010

    Speakers switching position on X-FI Elite Pro

    When i watch a movie in 5.1 config or plays games it sometimes switches my speakers so my speakers change to this.
    Front left changes to Center
    Center changes to Rear left
    Front Right changes to Bas
    Rear left changes to Front Left
    Rear Right changes to Front Right.
    And when i go to test my speaker conf in the audio console and plays. The test it will do this conf i told you above, clicking on front left speaker gives me center etc. To fix this i only need to close the program i was using Windows Media Player, or Winamp, game or anything that i used. When closing them the audio gets restored to the right one, left is left etc. Then the speaker test in audio console works flawless. Same thing happens during headphone mode but there you hear that the cmss3d fails and gives a dull sound. I asked creative support and they are ready to give me an RMA because they have no idea why this is happening, but several weeks without any soundcard and sound is not fun (no onboard sound) so i ask this forum people about how i can solve this or someone else have this problem. I got this problem when i installed the Vista 64bit driver (the third (3) one when vista launched) before that it worked flawless.

  2. #2
    Join Date
    Dec 2010

    Re: Speakers switching position on X-FI Elite Pro

    i have the same problem with my XFI extreme gamer 20 times a day, the boxes change their role. On 32bit vista the problems are gone with driver 0008. With VISTA 64, that i use since 3 months, the problems are still there. No other soundcard have such a problem, also my onboard card (VIA HD AUDIO) works great with vista but the SoundBlaster have this speaker switch problem. Under XP the card works perfect only under vista. The XFI drivers for vista are the crapiest thing I’ve ever see. i would switch to the VIA onboard card, but they didnīt have a SVM feature that’s the only reason for using the XFI. And the problem is still present since vista was launched (2007) i donīt think creative will fix this problem.

  3. #3
    Join Date
    Feb 2011

    Re: Speakers switching position on X-FI Elite Pro

    I have the exact same problem with my X-Fi Xtreme Gamer in Vista 64. I can't watch movies in surround sound, only 2.1 because the audio shifts several times throughout the movies. The audio shifts channels precisely the same way the OP stated. We surely can't be the only people experiencing this problem.
    This is running on the following rig:
    Gigabyte GA-MA78GM-S2H
    AMD Phenom X4 9850 Black
    OCZ Platinum 4GB (4 x 1GB) 240-Pin DDR2 SDRAM DDR2 1066
    ATI Radeon 3870 512mb
    Antec BP550 plus 550 watt continuous power ATX 12v
    Creative Labs Xtreme Gamer
    Vista Ultimate 64bit - retail box, fully up to date.

  4. #4
    Join Date
    Feb 2011

    Re: Speakers switching position on X-FI Elite Pro

    I have this EXACT same problem. On the 2.18.0013s on my X-FI XtremeGamer Fatal1ty Pro on my system running Win 7 x64 RTM. I also notice when it does happen, certain programs will no longer work until I restart the machine (Winamp, WMP, XFire, Ventrilo). About to pull this card out and sell it and go back to onboard sound. I've about had it with the buggy drivers. It also did this to me when I had Vista x64 SP1 on my system as well. System specs are below:
    Intel Core 2 Duo E8400 @ 4.16GHZ (does this as stock clocks as well)
    8GB ADATA PC2-6400 RAM
    2x XFX NVidia GeForce GTX260 XXX cards in SLI
    EVGA nForce 680i SE
    X-FI XtremeGamer Fatal1ty
    2x74GB WD Raptors
    2x500GB WD Caviars
    CoolerMaster 850W PSU
    Hopefully someone has figured out a resolution to this problem?

  5. #5
    Join Date
    Feb 2011

    Re: Speakers switching position on X-FI Elite Pro

    Has anyone tried to contact Creative for this issue? I just started to have this issue. I am running a fresh install of Windows 7 x64. Tried installing latest drivers (2.18.0013) from Creative and still having issues. Anyone got a quick fix or is Creative going to fix this? It is annoying when the speakers switch when watching a movie.
    Sys Conifg:
    Asus Rampage Formula
    Intel QX6850 oc'ed to 3.6GHZ
    Corsair 4 GB DD2 1066MHZ
    WD Raptor 300GB
    XFX Geforce 8800 GTX
    Creative X-Fi XtremeGamer Fatal1ty
    Logitech Z-5500 5.1

Similar Threads

  1. headphones and external speakers donot turnoff inbuilt speakers
    By jjazzy184 in forum Operating Systems
    Replies: 7
    Last Post: 20-09-2011, 05:26 PM
  2. Sound Through Laptop Speakers and External Speakers
    By Mitchp911 in forum Windows Software
    Replies: 2
    Last Post: 09-07-2010, 02:28 PM
  3. Rear speakers not working of Philips 5.1 speakers in my desktop
    By Amolya Tikam in forum Hardware Peripherals
    Replies: 5
    Last Post: 05-02-2010, 09:06 PM
  4. Normal speakers or amplifier plus speakers?
    By Emily 2 in forum Hardware Peripherals
    Replies: 2
    Last Post: 12-08-2008, 03:16 PM
  5. Nokia Mini-Speakers MD-6 (Big stereo sound speakers)
    By Yaropolk in forum Portable Devices
    Replies: 0
    Last Post: 06-08-2008, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts