Results 1 to 8 of 8

Thread: World of Warcraft Wireless Headset not working after updating driver

  1. #1
    Join Date
    Mar 2011
    Posts
    69

    World of Warcraft Wireless Headset not working after updating driver

    Today I have received my new headset, and connect to the PC these worked without problems, for some reason decided to update the drivers and firmware for the headphones, and after doing that, now it does not work, turn on, but no sound. Any solution? There a way to return to the previous firmware? Please help me to solve this problem I try to find about this on internet but not able to find appropriate solution on this. Please share your knowledge with me thank you.

  2. #2
    Join Date
    Mar 2011
    Posts
    72

    Re: World of Warcraft Wireless Headset not working after updating driver

    I am also having the same issue with the firmware upgrade and want to go back to factory firmware. It worked just fine until I upgraded to the latest firmware driver from the Creative site. You guys should revisit that driver and either fix it or remove it from the site, in my opinion. Now it wonít connect at all, the mic doesnít work, the sound doesnít work. It shows up as usual in the sound options and device manager in Win 7 64bit, you can select both the phones and mic but it doesnít do any good to select them. I must have done it 100 times, every different combo, and I have other items that work just fine so its NOT windows causing it.

  3. #3
    Join Date
    May 2008
    Posts
    1,275

    Re: World of Warcraft Wireless Headset not working after updating driver

    I am assuming you successfully completed the firmware upgrade? No errors? What I did was upgrade the firmware and reboot. I uninstalled all Creative WoW software and removed the USB stick and rebooted. I checked that my standalone sound card now works fine. Then I reinstalled the newest WoW software. It has been updated since release in early March. I had a March 6th version. The version of the software now is listed as March 23rd compilation date. I reinstalled that and it worked much better for me.

  4. #4
    Join Date
    May 2008
    Posts
    1,395

    Re: World of Warcraft Wireless Headset not working after updating driver

    I had the same problem, to fix this, hold down the connect button on the USB Transmitter Stick while your headset is searching for a connection. If that doesn't work hold down the connect button on the headset for about 5 seconds after you've already held down the USB Transmitter stick button and the blue arrow led starts bilking quickly. It should work then. I hope this will help you to solve your problem. If you find any other solution on it then share your experiences with us thank you.

  5. #5
    Join Date
    Mar 2011
    Posts
    69

    Re: World of Warcraft Wireless Headset not working after updating driver

    I am also unable to pair my headset with the USB transmitter after upgrading to the latest firmware. I have tried all the suggestions here, but I have been unsuccessful. Has anyone received a response from the creative support people? I cannot log a ticket, because I donít have a record of the serial number - anyone knows of a utility which will query the device for its number? Please share you knowledge with us. All replies are appreciated.

  6. #6
    Join Date
    Mar 2011
    Posts
    72

    Re: World of Warcraft Wireless Headset not working after updating driver

    I just bought the wireless Wow headset today. I went to the site like the quick guide says. I downloaded both the firmware patch and the latest Wow drivers. I had an error on the driver install but if found a fix on the wow forums to get around it (Windows 7 64bit). I restarted and then found out neither my Lenses worked (lights) or microphone. I hadnít even changed a setting whatís up with that. I paid AUD 249.00 for this headset, I was expecting no issues. I have sent a ticket off to creative in some hope in getting a way to revert the firmware.

  7. #7
    Join Date
    Mar 2011
    Posts
    69

    Re: World of Warcraft Wireless Headset not working after updating driver

    I have to say nevertheless. Customer support responded to me last night and it works just fine now. I had to make sure my cache/temp/history was all cleaned out so not to have bad files from previous downloads. Also suggested that I use Internet Explorer to do the download. Once it downloaded and I made sure it was the 66.6 MB file. Shut all programs off, ran the setup and it installed great. Have the audio control panel and it recognizes the Tap Chat device. Support gets a bad knock, but they helped me.

  8. #8
    Join Date
    Apr 2011
    Posts
    1

    Re: World of Warcraft Wireless Headset not working after updating driver

    Quote Originally Posted by Zilar View Post
    I have to say nevertheless. Customer support responded to me last night and it works just fine now. I had to make sure my cache/temp/history was all cleaned out so not to have bad files from previous downloads. Also suggested that I use Internet Explorer to do the download. Once it downloaded and I made sure it was the 66.6 MB file. Shut all programs off, ran the setup and it installed great. Have the audio control panel and it recognizes the Tap Chat device. Support gets a bad knock, but they helped me.
    Could you please lend me some more information? What operating system do you have?

    I've tried to clear out my temp-directories after an uninstall and then installed it again, without success.

    I do have Windows 7 x64, same case for you?

Similar Threads

  1. Replies: 3
    Last Post: 12-03-2012, 08:33 AM
  2. Warcraft Wireless Headset gives Cracking noise
    By Althea in forum Hardware Peripherals
    Replies: 4
    Last Post: 20-04-2011, 11:40 PM
  3. World of Warcraft Headset sound breaking on Macbook pro
    By Gentza in forum Hardware Peripherals
    Replies: 4
    Last Post: 20-04-2011, 10:34 PM
  4. Replies: 4
    Last Post: 19-04-2011, 02:52 AM
  5. Wired World of Warcraft headset
    By Braasch in forum Hardware Peripherals
    Replies: 5
    Last Post: 03-07-2010, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •