Results 1 to 6 of 6

Thread: Centre and rear speakers of Logitech X 530 are not working

  1. #1
    Join Date
    Jan 2011
    Posts
    65

    Centre and rear speakers of Logitech X 530 are not working

    I like to listen loud musing and therefore I bought the Logitech X 530 speakers but now I am facing some problem with this. Actually, I have set them to 5.1 from the control panel and when I tested that from the control panel that was on the bottom right of the task bar then I found that all the things where working fine. But when I tried to play music or movies on that then I found that the Centre and rear speakers of that were not giving me any sound from them. Can you tell me that what can be the problem with that and how can it be solved? I will appreciate each and every reply on this.

  2. #2
    Join Date
    Oct 2005
    Posts
    725

    Re: Centre and rear speakers of Logitech X 530 are not working

    As you said that the test was working fine then I can say that all the things are working fine and it is normal. I would like to tell you that the music is only stereo normally and that is the reason that you will just obtain stereo output. This is from the front left, front right and sub. This is a byproduct of media player as well as source files. A few media players and a few speaker systems can get a stereo source as well as duplicate it to rear speakers. Therefore you acquire stereo audio lying on four speakers. A few audio chipset software will get a stereo source as well as duplicate it to rears otherwise make surround sound.

  3. #3
    Join Date
    Mar 2010
    Posts
    2,091

    Re: Centre and rear speakers of Logitech X 530 are not working

    You must be aware that movie audio is somewhat dissimilar. Assuming that you are having the DVD by means of DD5.1 then you will require an audio chipset otherwise speaker system which will be able to decode the DD5.1 otherwise DTS audio stream. This can also be through software by means of the suitable audio codec I consider, but hold up may differ and that totally depends on media player used.

  4. #4
    Join Date
    Mar 2010
    Posts
    2,713

    Re: Centre and rear speakers of Logitech X 530 are not working

    If you are able to listen the audio from the front left as well as right speaker while playing stereo mp3 files otherwise audio CD's, then speakers are functioning properly. The speakers just duplicate the audio in the innovative file. That is having the 5.1 speakers does not mean each audio source played in computer will be within surround resonance. If you play any audio like a stereo mp3 file, you will obtain standard audio as of front left/right speakers. If you run any game otherwise movie by means of a 5.1 audio track then you will obtain 5.1 surround sound.

  5. #5
    Join Date
    Mar 2010
    Posts
    2,470

    Re: Centre and rear speakers of Logitech X 530 are not working

    As you told that you bought it new. So if you have tried all the above solution and you are not able to solve the problem then the best way is to contact the dealer of the product. I am sure that it will be under warranty period. They will setup that for you without any charge as that is under warranty period. This is the best way as I think and you should give this more priority before trying anything else to it. I wish that you will be out of the issue soon.

  6. #6
    Join Date
    Nov 2009
    Posts
    869

    Re: Centre and rear speakers of Logitech X 530 are not working

    Hey this seemed to be near the problem I'm having, but I'm one step worse. I just bought the Logitech X-540 and set all peripherals related to 5.1, etc, etc. Technology'm not a child, but not stupid. After 2 hours of fiddling around I still can not get SL, SR to produce any sound at all. Even through the actual test control panels. These two speakers are working correctly as I can be tested in the wrong port. This is just strange, because the rest of the speakers are working properly! Back right and back left are working on the game and more sub-center are working excellently, but I'm not getting my stero base, this has caught me.

Similar Threads

  1. Replies: 4
    Last Post: 27-05-2011, 05:52 AM
  2. Rear Surround Speakers not working from my Onkyo
    By ScarFace 01 in forum Hardware Peripherals
    Replies: 10
    Last Post: 17-06-2010, 07:06 AM
  3. Logitech Z4 speakers not working
    By Delgado in forum Portable Devices
    Replies: 5
    Last Post: 12-06-2010, 01:55 AM
  4. Rear speakers not working of Philips 5.1 speakers in my desktop
    By Amolya Tikam in forum Hardware Peripherals
    Replies: 5
    Last Post: 05-02-2010, 08:06 PM
  5. Bose rear speakers not working
    By Yudhajit in forum Hardware Peripherals
    Replies: 3
    Last Post: 19-05-2009, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •