Go Back   TechArena Community > Hardware > Hardware Peripherals
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Lexmark printer no longer works on usb not wireless after snow leopard

Hardware Peripherals


Reply
 
Thread Tools Search this Thread
  #1  
Old 20-10-2010
Member
 
Join Date: Oct 2010
Posts: 65
Lexmark printer no longer works on usb not wireless after snow leopard
  

Only the title is enough to explain the reality of the problem. My printer is supported(x4690) and it is working fine when it is connected via USB cable but when I try to connect that wirelessly then it started showing me the problem and I am not able to establish the proper connection to my printer and my computer. I have already tried everything that I know to solve the problem.

The only thing that I know about this error is when I try to print any document and run the log for that then it shows me some error message that is given below:

Stopping job because the scheduler could not execute a filter.
E [30/Aug/2009:14:17:13 +0100] Unable to execute /usr/libexec/cups/backend/lexnet3: insecure file permissions (0100755)

Please help if you have any suggestion for this issue. Any helpful suggestion with this problem will be really appreciative.

Reply With Quote
  #2  
Old 20-10-2010
Member
 
Join Date: Nov 2005
Posts: 2,326
Re: Lexmark printer no longer works on usb not wireless after snow leopard

I think that you have to contact to the Lexmark for such problems. They are the people who knew that what are the possible errors that can be happen to the Lexmark printer and they also have the proper solution for that. Just contact then and ask them for the issue that you are facing, I am sure that they will provide you the best answer for you and that will work in your case. This will be best and the safest way to get answer for the issues like this. I am also using Lexmark printer and for any problem like this directly contact them and they provide the best solution for it. I hope you will also get the solution for your printer.
Reply With Quote
  #3  
Old 20-10-2010
Member
 
Join Date: Nov 2005
Posts: 2,475
Re: Lexmark printer no longer works on usb not wireless after snow leopard

Hey, I managed to fix this issue in my case. In my case the driver was not the problem because it was getting connected with the USB cable. Network was also fine because all the other computers in my house can use and print the documents to the printer.

To fix the problem, I manually connected the printer. To do that, you have to go to printers in the system preferences. There you will see the plus sign. Just click on that to add the printer. You will see a tab called IP, select that and put the IP address of the printer that you will get from the printer. Then you have to call the Lexmark and then select the correct driver from the list of the drivers. Install that in your computer and in my case it worked. I hope this will help others also who is facing similar problem.
Reply With Quote
  #4  
Old 20-10-2010
Member
 
Join Date: Nov 2005
Posts: 2,485
Re: Lexmark printer no longer works on usb not wireless after snow leopard

I was also having the same problem and to fix that I tried optional installs from the SL disk and after that I went to Apple site to check for the drivers. Here is the link for that site: support.apple.com/kb/DL901?vi...S&locale=en_GB. I knew that I was having the correct driver because it was able to print with the USB. After that I deleted the lexmark from preferences and after deleting that I added the new printer to it. You can add this through the IP address and then you have to add the printer software from option dropdown and then you will get the correct lexmark driver which will solve the problem for you.
Reply With Quote
  #5  
Old 20-10-2010
Member
 
Join Date: May 2006
Posts: 2,786
Re: Lexmark printer no longer works on usb not wireless after snow leopard

The solution which is given here may not be the permanent solution for you. The exact problem is that the driver remembers the location of all the printers by its IP address. If the DHCP server or I can say your router assigns a new IP address to your printer then this comes up with the problems like this. The drivers, which is in your mac is not able to find that. The solution for this is to assign fix IP address for the printer and this will fix the issue for you permanently and you will not get this error in future. According to me this is the only possible solution to fix this error forever and there is no alternative solution for this.
Reply With Quote
Reply

  TechArena Community > Hardware > Hardware Peripherals
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Lexmark printer no longer works on usb not wireless after snow leopard"
Thread Thread Starter Forum Replies Last Post
Please walk me through adding a network printer in Snow Leopard MicroDon Networking & Security 5 20-10-2010 12:43 PM
Epson Printer issue after Snow Leopard Upgrade Micmac Hardware Peripherals 6 29-05-2010 12:33 PM
Printer driver update in snow leopard Romany Hardware Peripherals 5 19-02-2010 09:26 AM
Canon Printer cannot work in Snow Leopard OS X Daniel23 Hardware Peripherals 5 21-01-2010 10:53 PM
Fix Snow Leopard and HP printer problems Kingfisher Hardware Peripherals 3 28-10-2009 02:20 PM


All times are GMT +5.5. The time now is 12:16 PM.