Results 1 to 5 of 5

Thread: Logitech G15 slowing down Bad company 2

  1. #1
    Join Date
    May 2009
    Posts
    210

    Logitech G15 slowing down Bad company 2

    Hi,
    I have Logitech G15 gaming keyboard. I am trying to play Bad Company 2 online with this keyboard. But as I move along the keyboard makes my movement extremely slow. Also after the installation of this keyboard I had found that the bootime time of my pc has gone too high. Sometime the windows welcome screen appears and nothing works after that. How to fix that.

  2. #2
    Join Date
    Nov 2005
    Posts
    2,327

    Re: Logitech G15 slowing down Bad company 2

    I had too found a similar issue. Here I had two keyboards. One is a usb keyboard normal and the other one is G15. When I use the normal one the game works fine. But as I use the other one G15 the game movements and booting time goes very high. The movements are too slow. I am not able to figure out where the issue lies. I re-installed the same many times.

  3. #3
    Join Date
    Nov 2005
    Posts
    2,485

    Re: Logitech G15 slowing down Bad company 2

    The issue is very common with G15. The boot screen remains black when you connect this keyboard to your computer. What you can do here is run device manager and then go to the keyboard. Right click on the same and uninstall it. Before re-install go on the official site and download the latest drivers for this keyboard. Install the same and check back again.

  4. #4
    Join Date
    Nov 2005
    Posts
    2,503

    Re: Logitech G15 slowing down Bad company 2

    It is due to incompatible drivers. If you are using Windows 7 then you will have to locate compatible drivers for this keyboard. Otherwise you will face similar issue. There is nothing related to the keyboard on the game. If you can checkout the control settings of Bad Company 2 then you can improve a bit performance of the same. Just search for the appropriate drivers.

  5. #5
    Join Date
    May 2006
    Posts
    2,819

    Re: Logitech G15 slowing down Bad company 2

    First boot your computer when the keyboard is attached. Then before running Bad Company 2 press Ctrl + Alt + Del. In the task manager go to process and then click on LGDCore.exe. End process this application. You have to terminate this. Now run the game and connect to the online server. Now try back and checkout the keyboard performance. You will notice a difference.

Similar Threads

  1. My droid is slowing down
    By Vanderbilt in forum Portable Devices
    Replies: 6
    Last Post: 30-06-2011, 09:59 PM
  2. Replies: 3
    Last Post: 13-12-2010, 02:18 PM
  3. What is helpsvc.exe , it is Slowing down my Pc
    By Abaan in forum Operating Systems
    Replies: 3
    Last Post: 13-07-2009, 12:10 PM
  4. Dumprep.exe Slowing Down my Computer
    By Aliya in forum Operating Systems
    Replies: 4
    Last Post: 11-02-2009, 01:20 PM
  5. wmiprvse.exe, Slowing down other applications
    By Hrishia in forum Windows XP Support
    Replies: 2
    Last Post: 24-05-2007, 12:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •