Go Back   TechArena Community > Hardware > Hardware Peripherals
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



File transfer problem with my external hard drive

Hardware Peripherals


Reply
 
Thread Tools Search this Thread
  #1  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 860
File transfer problem with my external hard drive
  

I have some problem with my external hard drive. When I transfer some small files I do not have any trouble but when I transfer large files over 300MB, it dies. Do you have tips to remedy it or is that my drive is a problem?

Reply With Quote
  #2  
Old 05-12-2008
Member
 
Join Date: Aug 2008
Posts: 474
Re: File transfer problem with my external hard drive

Which version of USB port are you having? USB 1 or USB 2? Ideally devices operate at normal speed in USB 2 (20-30 MB/sec max). What operating system? Also SP?
Reply With Quote
  #3  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 1,275
Re: File transfer problem with my external hard drive

USB 1 is also good and it transfers data at the rate more than 900kB/sec. According to me, it resembles more a problem of USB to IDE controller driver.
Reply With Quote
  #4  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 860
Re: File transfer problem with my external hard drive

I was using Windows XP Pro. But now I have switched to Windows Vista and I would say it's the same problem. I even connected to my hub, no difference. Under vista there is an option for a faster transfer level, again no difference. Since I have just installed Vista, I imagine that I have the right drivers.
Reply With Quote
  #5  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 1,275
Re: File transfer problem with my external hard drive

Check the Device Manager if your disc is PIO, DMA, UltraDMA.
Reply With Quote
  #6  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 860
Re: File transfer problem with my external hard drive

Well I do not know where I should go specifically for this setting, but in Device Manager, disk drive, I have my external HD, I checked the option "optimize for better performance" and I actually got a better flow with this time around 8.5 MB/sec for a record average of 18 GB.
Reply With Quote
  #7  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 1,275
Re: File transfer problem with my external hard drive

Go to My Computer -> Right click and select Properties -> Manage -> Device Manager.

Here you have a list of all devices, see if there is a "!" yellow possibly somewhere.

Also check the IDE controllers of your internal disk, (controllers ATA / ATAPI / IDE) and verify that their methods are UltraDMA transfers and not PIO (in this case, slow is not due to your external drive, but the internal drive)

On Device Manager, Expand IDE Controllers -> Right click on IDE channel, select properties -> Advanced Settings
Reply With Quote
  #8  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 860
Re: File transfer problem with my external hard drive

I went there and saw that it is Ultra DMA. I've no exclamation mark in the device manager. So could it be drive problem or file is corrupted?
Reply With Quote
  #9  
Old 05-12-2008
Member
 
Join Date: May 2008
Posts: 1,275
Re: File transfer problem with my external hard drive

So your internal disk is operating properly. You can try on different USB ports and/or another external hard drive.
Reply With Quote
Reply

  TechArena Community > Hardware > Hardware Peripherals
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "File transfer problem with my external hard drive"
Thread Thread Starter Forum Replies Last Post
How to transfer files from a mac external hard drive to a windows hard drive first-born Operating Systems 4 03-11-2010 09:39 AM
Transfer mkv files external hard drive Nevermore Windows Software 4 18-02-2010 07:48 PM
External Hard drive problem with files transfer Manik Hardware Peripherals 4 10-01-2009 06:18 PM


All times are GMT +5.5. The time now is 03:07 AM.