Results 1 to 4 of 4

Thread: Netlogon Server doesn't start

  1. #1
    Join Date
    Jan 2005

    Netlogon Server doesn't start

    HI, Iím running a Windows Server 2003 Standard Edition R2 with Service Pack 1. It has only one DC running. Donít know why suddenly my Netlogon stopped working and is not starting anymore. Due to this my entire domain is down. I tried searching web for some help but dint found anything helpful. Hope you guys can help me out with this.

    Here is what I found listed in the Event Log:
    event log
    Userenv ID 1053
    Can't determine computer's role (specified user does not exists).

    Nelogon ID 5602
    erro accessinf local computer or network

    Directory Service
    NTDS General ID 1126
    Can't contact the global catalog

    No errors
    In my DBS forward lookup zone I see only the A record of my server (and not
    the records of the several client)
    And here is the netlogon log:

    07/13 10:55:16 [SESSION] NlCheckServerSession: SEGRETERIA2: Added NT BDC
    07/13 10:55:19 [MISC] Added the 0x1B name on transport
    07/13 10:55:19 [CRITICAL] NetpDcGetDcNext:
    _ldap._tcp.pdc._msdcs.galassiregni.: Cannot Query DNS. 1460 0x5b4
    07/13 10:55:19 [CRITICAL] NetpDcGetNameIp: galassiregni.: No data returned
    from DnsQuery.
    07/13 10:55:19 [MAILSLOT] Sent 'Primary Query' message to GALASSIREGNI[1B]
    on all transports.
    07/13 10:55:27 [MAILSLOT] Sent 'Primary Query' message to GALASSIREGNI[1B]
    on all transports.
    07/13 10:55:27 [MAILSLOT] Sent 'Primary Query' message to GALASSIREGNI[1C]
    on all transports.
    07/13 10:55:34 [DOMAIN] Setting this machine to be a PDC that replicates to
    NT 4 BDCs
    07/13 10:55:34 [SYNC] NlInitDbSerialNumber: SAM: Serial number is 0 13c
    07/13 10:55:34 [SYNC] NlInitDbSerialNumber: BUILTIN: Serial number is 0 2f
    07/13 10:55:34 [SYNC] NlInitDbSerialNumber: LSA: Serial number is 0 14
    07/13 10:55:34 [CRITICAL] Cannot NlSamOpenNamedUser 0xc0000064
    07/13 10:55:34 [MISC] NlExit: Netlogon exiting 5602 0x15e2 Data: 3221225572
    07/13 10:55:34 [MISC] Eventlog: 5602 (1) 0xc0000064 c0000064 d...
    07/13 10:55:34 [DOMAIN] NlDeleteDomain called
    07/13 10:55:34 [DOMAIN] Domain RefCount is zero. Domain being rundown.
    07/13 10:55:34 [SESSION] NlFreeServerSession: SEGRETERIA2: Freed server
    07/13 10:55:34 [SITE] Setting site name to '(null)'
    Somebody please help me to get out of this.

  2. #2
    Join Date
    Sep 2004

    Re: Netlogon Server doesn't start

    Before I could I suggest a proper solution, I must know the proper cause of this problem. So, did you made any changes in the server just before its failure such as Windows Update or such things? Also how did you lose the dc in the first place? Until youi reply these questions, just give this a try.

    Open command prompt, enter netdiag /fix. See if running command can repopulate the dns records for your dc. Apart from this also try to run diagnostics against your Active Directory domain. See if it works. Let me know the results with answer for the questions I asked you above.

  3. #3
    Join Date
    Jan 2005

    Re: Netlogon Server doesn't start

    Thank you very much for your help Oshea. As you suggested, i ran the netdiag and following is the output (only errors)

    [FATAL] File \config\netlogon.dns contains invalid DNS entries.
    [FATAL] No DNS servers have the DNS records for this DC registered.

    DNS test . . . . . . . . . . . . . : Failed
    Interface {6ADA4C65-2827-4B37-88F1-84FF14153A82}
    DNS Domain:
    DNS Servers:
    IP Address: Expected registration with PDN (primary DNS
    domain name):
    Hostname: server.galassiregni.
    Authoritative zone: galassiregni.
    Primary DNS server: server.galassiregni
    Authoritative NS:
    Check the DNS registration for DCs entries on DNS server ''
    [FATAL] File \config\netlogon.dns contains invalid DNS entries.
    [FATAL] No DNS servers have the DNS records for this DC registered.

    DC discovery test. . . . . . . . . : Failed

    Find DC in domain 'GALASSIREGNI':
    [FATAL] Cannot find DC in domain 'GALASSIREGNI'.

    DC list test . . . . . . . . . . . : Failed
    'GALASSIREGNI': Cannot find DC to get DC list from [test skipped].
    List of DCs in Domain 'GALASSIREGNI':

    LDAP test. . . . . . . . . . . . . : Failed
    Cannot find DC to run LDAP tests on. The error occurred was: The
    specified domain does not exists or it is unreachable

    What now? Please help.

  4. #4
    Join Date
    Sep 2004

    Re: Netlogon Server doesn't start

    Well, according to your test and results, to me it probably appears as DNS issue. Where is your DNS server located? If the DC is also set as DNS server then just make sure that your DNS server is installed. Also make sure that server NIC primary DNS is pointing to the server itself. Note, DNS must have Domain Forward Zone configured.

Similar Threads

  1. Replies: 3
    Last Post: 19-01-2012, 11:45 PM
  2. OpenSolaris doesn't start
    By FreeBSD in forum Operating Systems
    Replies: 3
    Last Post: 08-10-2009, 02:41 PM
  3. Event ID: 5721 Event Source: NETLOGON member server windows 2003
    By Edwin Delgado in forum Windows Server Help
    Replies: 1
    Last Post: 08-09-2007, 01:41 AM
  4. Event ID:5719-Netlogon on Windows Server 2003
    By Victor Kam in forum Active Directory
    Replies: 1
    Last Post: 07-05-2007, 07:20 PM
  5. Unable to create share through Netlogon on Windows Server
    By Victor Kam in forum Active Directory
    Replies: 2
    Last Post: 20-04-2007, 04:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts