Results 1 to 5 of 5

Thread: Infrastructure FSMO role owner attibute not correct in root domain

  1. #1
    Join Date
    Sep 2005
    Posts
    138

    Infrastructure FSMO role owner attibute not correct in root domain

    I am getting the below error message in my OpsMgr 2007 that tells me that my root domain has some issue:

    AD Replication Monitoring : encountered a runtime error.
    Failed to obtain the InfrastructureMaster using a well known GUID.
    The error returned was: 'Failed to get the 'fSMORoleOwner' attribute from the object 'LDAP://cservername.domain.subdomain.net/<WKGUID=2fbac1870ade11d297c400c04fd8d5cd,DC=ForestDnsZones,DC=eccocorp,DC=net>'.
    The error returned was: 'The directory property cannot be found in the cache. ' (0x8000500D)' (0x8000500D)

    And after following an article to solve this, I have got an error on the infrastructure object in AD that points to a probably deleted DC. But afterwards when changing it in ADSI Edit I am getting the below error:

    Operation Failed. Error code: 0x20ae
    The role owner attribute could not be read

    000020AE: SvcErr: DSID-03152BF7, Problem 5003
    (WILL_NOT_PERFORM) Data 0

    Any ideas?

  2. #2
    Join Date
    Nov 2005
    Posts
    625
    Can you tell us what is the current IM role holder? Can you check with "netdom query fsmo", is it still online and accessible? Could you post and output from "netdom query fsmo" and also run diagnostics tools dsdiag /v and netdiad /v, repadmin /showrepl if more DC's exist.

  3. #3
    Join Date
    Oct 2004
    Posts
    1,342
    Have you got the proper permissions like the domain admin. Usually, the way to assign a new role owner to the IM of the app NC is to write a new valure into it. It should be the DN of the NTDS Settings object of an existing DC. In the meanwhile you can also check this link - http://support.microsoft.com/kb/949257

  4. #4
    Join Date
    Sep 2012
    Posts
    1
    I'm trying to do this but I'm getting the same error despite trying to make the change on the FSMO master itself.

    The error is;
    **************
    Operation failed. Error code 0x20ae
    The role owner attribute could not be read

    000020AE: SvcErr: DSID-03152965, problem 5003
    (WILL_NOT_PERFORM), data 0
    **************

    I'm trying to edit the fSMORoleOwner attribute on the FSMO role owner itself.

    So Im updating the fSMORoleOwner attribute with;

    CN=NTDS Settings,CN=MY-SBS1,CN=Servers,CN=Southwark,CN=Sites,CN=Configuration,DC=mydomain,DC=local

    and I'm on the MY-SBS1 server.

    Any ideas why it would still be stopping me?

  5. #5
    Join Date
    Dec 2007
    Posts
    2,291

    Re: Infrastructure FSMO role owner attibute not correct in root domain

    Hi oliverm,

    You can resolve the problem if the partition no longer exists, perform a metadata cleanup for the orphaned partition using the "remove nc" parameter of the Dsmgmt tool. For more information, visit the following Microsoft Web site:
    http://technet.microsoft.com/en-us/l...70(WS.10).aspx

Similar Threads

  1. How to get rid of server with FSMO Role
    By BalakrishnaB in forum Active Directory
    Replies: 3
    Last Post: 08-02-2012, 05:32 AM
  2. Change email domain for source IO Owner
    By Marjorie in forum Technology & Internet
    Replies: 5
    Last Post: 24-08-2010, 02:43 AM
  3. 2008 R2 FSMO Role Distribution
    By m3pilot in forum Active Directory
    Replies: 2
    Last Post: 28-05-2010, 10:25 PM
  4. Replies: 1
    Last Post: 13-07-2009, 05:29 PM
  5. FSMO role cannot transfer
    By Donald in forum Active Directory
    Replies: 4
    Last Post: 04-05-2006, 08:02 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,635,206,052.63004 seconds with 16 queries