Results 1 to 4 of 4

Thread: dsquery -limit command not working

  1. #1
    Join Date
    Nov 2004

    dsquery -limit command not working

    As my title says I知 facing some problem with dsquery -limit command. I wanted to know return more than 100 results from AD. For doing the same I used the following command:

    dsquery user OU=_Users,OU=DCA,OU=Locations,DC=sm,DC=doi,DC=net 窶斗imit 300 |
    dsget user -dn -desc -profile -hmdir -loscr > adusersv3.txt
    But I guess I知 making some mistake due to which it keeps on giving me the following error message:

    電squery failed:`-limit' is an unknown parameter.
    type dsquery /? for help.dsget failed:`Target object for this command' is missing.

    So I request you people to please help me out and let me know the proper method.

    Thank you very much.

  2. #2
    Join Date
    Jan 2006
    As far as i know the problem may when dsget encountered a user with a Common Name that contains an embedded quote.

    There may be possibilities that you might have a similar user name? SO i'll suggest you to try troubleshooting by changing the -limit value. Hope it works.

  3. #3
    Join Date
    Nov 2004

    Re: dsquery -limit command not working

    I appreciate your help Janos. But can you please be more specific what exactly you mean by "similar user name". However I changed the limit to 200 and still get the same error.Thanks again.

  4. #4
    Join Date
    Sep 2010

    Re: dsquery -limit command not working

    I know what you are doing wrong. It is the syntax that is incorrect. To keep it simple, if you would like to list all objects in Active Directory, use the following:

    dsquery * -limit 10000
    You have to give the amount to limit the search by. I believe you are using the following syntax instead...

    dsquery * -limit
    You can modify as needed to suit your needs.

Similar Threads

  1. Replies: 5
    Last Post: 14-08-2010, 11:25 PM
  2. Upload limit not working in uTorrent
    By Erinyes in forum Technology & Internet
    Replies: 6
    Last Post: 26-06-2010, 10:26 AM
  3. How to limit upload limit for each torrent
    By Asclepius in forum Technology & Internet
    Replies: 6
    Last Post: 18-06-2010, 06:05 AM
  4. dsquery and dsget
    By aconti in forum Active Directory
    Replies: 1
    Last Post: 01-11-2009, 04:09 PM
  5. Command prompt "COPY" command not working in brand new Windows Vis
    By CMD COPY command not working in Vista in forum Vista Help
    Replies: 7
    Last Post: 06-02-2008, 02:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts